Browser Support

To ensure full functionality in the Losant environment, you need to run the app on a supported web browser. Losant supports the two most recent versions of each browser below unless otherwise stated:

Note: We strongly recommend using a modern web browser. All platform features may not be supported in legacy browsers.

Important

The supported browsers listed here apply to Losant tools, not public-facing Experiences. Browser support for content created in and hosted by Losant will vary depending on the HTML, CSS, and JavaScript used within in your Experiences.

Mac

  • Google Chrome - Latest version
  • Mozilla Firefox - Latest version
  • Apple Safari - Latest version
  • Microsoft Edge - Latest version

Windows

  • Google Chrome - Latest version
  • Mozilla Firefox - Latest version
  • Microsoft Edge - Latest version
  • Microsoft Internet Explorer (IE) - Latest version of IE11. Versions of Internet Explorer 10 and below are not supported, because they are not fully supported by Microsoft.

Linux

  • Google Chrome - Latest version
  • Mozilla Firefox - Latest version

Updating Your Browser

Below you can find instructions on both installing and updating the supported browsers:

  • Google Chrome: Install | Update
  • Mozilla Firefox: Install | Update
  • Microsoft Edge: Install | Update
  • Apple Safari: Safari comes pre-installed with macOS, and is updated along with the operating system.